Page 1 of 1

Arch PKGBUILD for the vtunerc kernel module and the client

PostPosted: Sat Dec 10, 2011 12:54 am
by __jata__
Enclosed you find not too nice PKGBUILD for the vtunerc kernel module and the client... Arch is not the distro of mine, so take it with a grain of a salt.
But it seems be working and perhaps it could help :)

Re: Arch PKGBUILD for the vtunerc kernel module and the clie

PostPosted: Sat Dec 10, 2011 1:30 pm
by DyL
It will help definetely. :)

Re: Arch PKGBUILD for the vtunerc kernel module and the clie

PostPosted: Sun Dec 18, 2011 11:07 am
by __jata__
Slightly improved version - now it should generate udev rules as well.

Re: Arch PKGBUILD for the vtunerc kernel module and the clie

PostPosted: Fri Dec 30, 2011 10:29 am
by DyL
Good job jata!!!. Very helpful stuff. Thanks buddy.

Re: Arch PKGBUILD for the vtunerc kernel module and the clie

PostPosted: Wed Jan 25, 2012 11:41 pm
by __jata__
Nice to hear... but because the development goes quickly, it might produce some problems in future. Please, keep me inform, if something fails.

Re: Arch PKGBUILD for the vtunerc kernel module and the clie

PostPosted: Sat Mar 03, 2012 11:33 pm
by DyL
I tried it on my new HTPC with i686 system.

Instalation failed:

==> Starting build...
gcc -march=i686 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -m64 -fPIC -DHAVE_DVB_API_VERSION=5 -c -o vtunerd-service.o ../../vtunerd-service.c
../../vtunerd-service.c:1:0: sorry, unimplemented: 64-bit mode not compiled in
make: *** [vtunerd-service.o] Error 1
==> ERROR: A failure occurred in build().
Aborting...

Re: Arch PKGBUILD for the vtunerc kernel module and the clie

PostPosted: Mon Mar 05, 2012 1:23 pm
by __jata__
Ufff... the problem is apparently here:
Code: Select all
 -m64

but I do not know why. And I cannot debug it, because I have no pure 32bit Arch available :( hmm... It works for me in the simulated environment (linux32 makepkg PKGBUILD):
Code: Select all
 ...
gcc -march=x86-64 -mtune=native -O2 -pipe -fomit-frame-pointer -ftracer -fstack-protector -fexpensive-optimizations --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -m32 -DHAVE_DVB_API_VERSION=5   -c -o vtunerd-service.o ../../vtunerd-service.c
gcc -march=x86-64 -mtune=native -O2 -pipe -fomit-frame-pointer -ftracer -fstack-protector -fexpensive-optimizations --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -m32 -DHAVE_DVB_API_VERSION=5   -c -o vtuner-network.o ../../vtuner-network.c
gcc -march=x86-64 -mtune=native -O2 -pipe -fomit-frame-pointer -ftracer -fstack-protector -fexpensive-optimizations --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -m32 -DHAVE_DVB_API_VERSION=5   -c -o vtuner-utils.o ../../vtuner-utils.c
In file included from /usr/include/string.h:642:0,
                 from ../../vtuner-utils.c:2:
In function ‘strncat’,
    inlined from ‘write_message’ at ../../vtuner-utils.c:31:12:
/usr/include/bits/string3.h:152:3: warning: call to __builtin___strncat_chk might overflow destination buffer [enabled by default]
In function ‘strncat’,
    inlined from ‘append_message’ at ../../vtuner-utils.c:68:10:
/usr/include/bits/string3.h:152:3: warning: call to __builtin___strncat_chk might overflow destination buffer [enabled by default]
gcc -march=x86-64 -mtune=native -O2 -pipe -fomit-frame-pointer -ftracer -fstack-protector -fexpensive-optimizations --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -m32 -DHAVE_DVB_API_VERSION=5   -c -o vtuner-dvb-3.o ../../vtuner-dvb-3.c
gcc -march=x86-64 -mtune=native -O2 -pipe -fomit-frame-pointer -ftracer -fstack-protector -fexpensive-optimizations --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -m32 -DHAVE_DVB_API_VERSION=5   -DBUILDVER="\"b6fa0d2b133b+/tip\"" -DMODFLAG=\"\" -o ../../dist/i686/vtunerc.i686 vtuner-network.o vtuner-utils.o ../../vtunerc.c -Wl,-O1,--sort-common,--as-needed,-z,relro,--hash-style=gnu -lpthread -lrt
../../vtunerc.c: In function ‘main’:
../../vtunerc.c:663:18: warning: ignoring return value of ‘write’, declared with attribute warn_unused_result [-Wunused-result]
../../vtunerc.c:664:17: warning: ignoring return value of ‘read’, declared with attribute warn_unused_result [-Wunused-result]
../../vtunerc.c:760:16: warning: ignoring return value of ‘write’, declared with attribute warn_unused_result [-Wunused-result]
../../vtunerc.c:777:19: warning: ignoring return value of ‘read’, declared with attribute warn_unused_result [-Wunused-result]
gcc -march=x86-64 -mtune=native -O2 -pipe -fomit-frame-pointer -ftracer -fstack-protector -fexpensive-optimizations --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -m32 -DHAVE_DVB_API_VERSION=5   -DBUILDVER="\"b6fa0d2b133b+/tip\"" -DMODFLAG=\"\" -o ../../dist/i686/vtunerd.i686 vtuner-network.o vtunerd-service.o vtuner-dvb-3.o vtuner-utils.o ../../vtunerd.c -Wl,-O1,--sort-common,--as-needed,-z,relro,--hash-style=gnu -lpthread -lrt
...
Skip the '-march=x86-64', this is because of 64bit Arch, but I DO have -m32 as the part of parameters, so why '-m64' for you?

Re: Arch PKGBUILD for the vtunerc kernel module and the clie

PostPosted: Sat Mar 10, 2012 11:35 pm
by DyL
I changed this line from
arch=('x86-64' 'i686')
to:
arch=('i686')

and it solved my problem on i686 arch system.